<!DOCTYPE html>
<html lang="en"
      dir="ltr" 
  xmlns:fb="http://www.facebook.com/2008/fbml"
  xmlns:og="http://ogp.me/ns#"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/web_smdr_logo_2018_master_favicon.png" type="image/png" />

<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.5.0/css/all.css" integrity="sha384-B4dIYHKNBt8Bc12p+WXckhzcICo0wtJAoU8YZTY5qE0Id1GSseTk6S+L3BlXeVIU" crossorigin="anonymous">
<meta name="theme-color" content="#ffffff" />
<meta name="description" content="Maggie Walsh is surprised by how fast she became committed to her dream school.[San Marcos, TX] [Hays County news] Sports San Marcos News, San Marcos Record [Texas State]" />
<meta name="robots" content="follow, index, nosnippet" />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="https://www.sanmarcosrecord.com/sports/maggie-walsh-stays-home-commits-texas-state" />
<link rel="shortlink" href="https://www.sanmarcosrecord.com/node/210589" />
<meta property="og:site_name" content="San Marcos Record" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.sanmarcosrecord.com/sports/maggie-walsh-stays-home-commits-texas-state" />
<meta property="og:title" content="Maggie Walsh stays home, commits to Texas State" />
<meta property="og:description" content="Maggie Walsh is surprised by how fast she became committed to her dream school." />
<meta property="og:updated_time" content="2020-12-12T13:24:54-06:00" />
<meta property="og:image" content="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/field/image/real_walsh_web_edit.jpg" />
<meta property="og:image:secure_url" content="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/field/image/real_walsh_web_edit.jpg" />
<meta property="article:published_time" content="2020-12-12T13:24:54-06:00" />
<meta property="article:modified_time" content="2020-12-12T13:24:54-06:00" />
    <title>Maggie Walsh stays home, commits to Texas State | San Marcos Record</title>
    <link type="text/css" rel="stylesheet" href="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/css/css_hIwihkVcNwxdN82aZiFHcdJIip_09fFCdxsB6cGN99I.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/css/css_z9taWdeW8YOHx78CeYyTmFttxcPk9G5tezKwkSK2SkA.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/css/css_LbmF5IpWBOrcGYGFTpVZPbM4thU08OHy7NjMm1Fu3OQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.sanmarcosrecord.com/sites/all/themes/cni/css/menu_break_767.css?ql7vnb" media="all" />
<style type="text/css" media="screen">
<!--/*--><![CDATA[/*><!--*/
#block-superfish-1, .sf-menu.sf-style-space li, .sf-menu.sf-style-space li li, .sf-menu.sf-style-space li li li, .sf-menu.sf-style-space.sf-navbar {background: #00a1e4 !important;}#main-menu #block-system-user-menu ul.menu {max-width: 800px !important;}
/*]]>*/-->
</style>
    <script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_L2nYPmaV8CBXoU9O-DqRpsh7T0FngWbkrLpn2Lry1xI.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_zSyBbtdXDHkAah3PgFNWkdl6BoNVXFzJYIBIrO2HD_M.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.slots["tpa_northsidebar"] = googletag.defineSlot("/116205717/TPA-Southsidebar", [300, 250], "dfp-ad-tpa_northsidebar")
  .addService(googletag.pubads());
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.slots["tpa_northleaderboard"] = googletag.defineSlot("/116205717/TPA-Southleaderboard", [728, 90], "dfp-ad-tpa_northleaderboard")
  .addService(googletag.pubads());
//--><!]]>
</script>
<script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_lsAVC4f7TrXTqRnJ6QSSrjpoSAAcBF-r-6fCfZusPis.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_Tfba9n-4Vzsg_DdgBvQWEg5x7LpgQtfQiBNb96OU_00.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
      // close script tag for SecKit protection
      //--><!]]>
      </script>
      <script type="text/javascript" src="/sites/all/modules/seckit/js/seckit.document_write.js"></script>
      <link type="text/css" rel="stylesheet" id="seckit-clickjacking-no-body" media="all" href="/sites/all/modules/seckit/css/seckit.no_body.css" />
      <!-- stop SecKit protection -->
      <noscript>
      <link type="text/css" rel="stylesheet" id="seckit-clickjacking-noscript-tag" media="all" href="/sites/all/modules/seckit/css/seckit.noscript_tag.css" />
      <div id="seckit-noscript-tag">
        Sorry, you need to enable JavaScript to visit this website.
      </div>
      </noscript>
      <script type="text/javascript">
      <!--//--><![CDATA[//><!--
      // open script tag to avoid syntax errors
//--><!]]>
</script>
<script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_HpAVL1IesV1C5x-CPUu6QgPOnR_179v3igWOpTxfWLY.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-38040460-1", {"cookieDomain":".sanmarcosrecord.com"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56e774978692f861"></script>
<script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_hYTVyaMdIAVK1kH943C5HYh2PLlmb7heyXkf3xPUy4Q.js"></script>
<script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_h0vKAiw8wygCUQKLi6QbuX0JvMuvKisnXrsxp_GJiMw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"sanmarcosrecord","theme_token":"vz7kz-rBgjH_q7zfQtUypt906ThQshkjEUxfb26R64Q","js":{"sites\/all\/modules\/addthis\/addthis.js":1,"misc\/jquery.js":1,"misc\/jquery-extend-3.4.0.js":1,"misc\/jquery-html-prefilter-3.5.0-backport.js":1,"misc\/jquery.once.js":1,"0":1,"https:\/\/www.googletagservices.com\/tag\/js\/gpt.js":1,"misc\/drupal.js":1,"1":1,"2":1,"sites\/all\/modules\/simpleads\/simpleads.js":1,"sites\/all\/modules\/simpleads\/modules\/simpleads_campaigns\/simpleads_campaigns.js":1,"sites\/all\/modules\/etype_sliderad\/sliderad.js":1,"3":1,"sites\/all\/modules\/external\/external.js":1,"sites\/all\/modules\/image_caption\/image_caption.min.js":1,"4":1,"sites\/all\/modules\/jcarousel\/js\/jquery.jcarousel.min.js":1,"sites\/all\/modules\/jcarousel\/js\/jcarousel.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"5":1,"\/\/s7.addthis.com\/js\/300\/addthis_widget.js#pubid=ra-56e774978692f861":1,"sites\/all\/modules\/etype\/js\/etype.js":1,"sites\/all\/libraries\/superfish\/jquery.hoverIntent.minified.js":1,"sites\/all\/libraries\/superfish\/superfish.js":1,"sites\/all\/libraries\/superfish\/supersubs.js":1,"sites\/all\/modules\/superfish\/superfish.js":1,"sites\/all\/themes\/cni\/js\/jquery.color.js":1,"sites\/all\/themes\/cni\/js\/jquery-glowing.js":1,"sites\/all\/themes\/cni\/js\/scripts.js":1,"sites\/sanmarcosrecord.etypegoogle4.com\/themes\/sanmarcosrecord\/js\/sanmarcosrecord.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"sites\/all\/modules\/calendar\/css\/calendar_multiday.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/date\/date_repeat_field\/date_repeat_field.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"sites\/all\/modules\/simpleads\/simpleads.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/etype_sliderad\/sliderad.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ed_classified\/theme\/classified.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/jcarousel\/skins\/default\/jcarousel-default.css":1,"sites\/all\/modules\/etype\/css\/styles.css":1,"sites\/all\/libraries\/superfish\/css\/superfish.css":1,"sites\/all\/libraries\/superfish\/css\/superfish-navbar.css":1,"sites\/all\/libraries\/superfish\/style\/space.css":1,"sites\/all\/themes\/cni\/css\/normalize.css":1,"sites\/all\/themes\/cni\/css\/formalize.css":1,"sites\/all\/themes\/cni\/css\/grid_12.css":1,"sites\/all\/themes\/cni\/css\/layout.css":1,"sites\/all\/themes\/cni\/css\/jcarousel.css":1,"sites\/all\/themes\/cni\/css\/galleria.css":1,"sites\/all\/themes\/cni\/css\/style.css":1,"sites\/sanmarcosrecord.etypegoogle4.com\/themes\/sanmarcosrecord\/css\/sanmarcosrecord.css":1,"sites\/all\/themes\/cni\/css\/menu_break_767.css":1,"0":1,"1":1}},"externalpdf":1,"jcarousel":{"ajaxPath":"\/jcarousel\/ajax\/views","carousels":{"jcarousel-dom-1":{"view_options":{"view_args":"","view_path":"node\/210589","view_base_path":null,"view_display_id":"block_1","view_name":"business_directory","jcarousel_dom_id":1},"wrap":"circular","skin":"default","responsive":1,"auto":4,"autoPause":1,"start":1,"selector":".jcarousel-dom-1"}}},"simpleads":{"url":{"ckeditor":"\/simpleads\/dashboard\/ckeditor"},"modulepath":"sites\/all\/modules\/simpleads"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackDomainMode":1},"urlIsAjaxTrusted":{"\/sports\/maggie-walsh-stays-home-commits-texas-state":true},"superfish":{"1":{"id":"1","sf":{"pathClass":"active-trail","pathLevels":"2","animation":{"opacity":"show"},"speed":"\u0027normal\u0027","autoArrows":false,"dropShadows":true,"disableHI":false},"plugins":{"supposition":false,"bgiframe":false,"supersubs":{"minWidth":"12","maxWidth":"27","extraWidth":1}}}},"cni":{"menu_break_point":"767"}});
//--><!]]>
</script>
    <link href="https://fonts.googleapis.com/css?family=Anton|Roboto" rel="stylesheet">
    <meta name="viewport"
          content="width=device-width, initial-scale=1, maximum-scale=1">
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <style>
#menu-6322-1 {
background-color: #FFCC00!important;
}
#menu-6322-1 a {
color: #000066!important;
}
</style>
<meta name="apple-itunes-app" content="app-id=1447143975">
<meta name="google-play-app" content="app-id=hr.apps.n207195768">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="stylesheet" href="/sites/all/libraries/smart-app-banner/dist/smart-app-banner.css" type="text/css" media="screen"></head>
<body class="html not-front not-logged-in two-sidebars page-node page-node- page-node-210589 node-type-article sanmarcosrecord sidebars-split sports maggie-walsh-stays-home-commits-texas-state">
<div id="fb-root"></div>
<script>(function (d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s);
        js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
        fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
<div id="skip-link">
    <a href="#main-content"
       class="element-invisible element-focusable">Skip to main content</a>
</div>
<div id="page-top">

    
            <nav id="user-menu" class="clearfix">
              <div class="region region-user-menu">
    <div id="block-search-form"
     class="block block-search">
    <div class="block-inner">

                  
        <div class="content">
          <form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/sports/maggie-walsh-stays-home-commits-texas-state" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-7u3CKWKXGiVTwO5y09qjTgKGaUWJPDC5xUgEi2B27n0" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>        </div>

    </div>
</div>
<div id="block-etype-social"
     class="block block-etype">
    <div class="block-inner">

                  
        <div class="content">
          
  <ul class="social-links"></ul>        </div>

    </div>
</div>
<div id="block-system-user-menu"
     class="block block-system block-menu">
    <div class="block-inner">

                      <h3 class="title">
              <span>User menu</span></h3>
            
        <div class="content">
          <ul class="menu"><li class="first leaf"><a href="http://archives.etypeservices.com/CDN/Media-Booklet-SMDR.pdf" title=""><span>Advertise</span></a></li>
<li class="leaf"><a href="/submit-event-calendar" title=""><span>Add Event</span></a></li>
<li class="leaf"><a href="/e-edition" title="Link to e-Edition."><span>e-Edition</span></a></li>
<li class="leaf"><a href="/river-flows" title=""><span>River Flows</span></a></li>
<li class="leaf"><a href="/sales-locations" title=""><span>Sales Location</span></a></li>
<li class="leaf"><a href="/webforms" title=""><span>Forms</span></a></li>
<li class="leaf"><a href="https://archives.etypeservices.com/CDN/CopyrightPolicy.pdf" title=""><span>Copyright</span></a></li>
<li class="leaf"><a href="/custom-login-page" title=""><span>Log In</span></a></li>
<li class="last leaf"><a href="/ada-compliance" title="Americans with Disabilities Act Compliance Statement"><span>Accessibility Policy</span></a></li>
</ul>        </div>

    </div>
</div>
  </div>
                    </nav>
    
    <div class="page-inner container_12">

        
        <div class="header-wrapper clearfix">
            <div class="header-wrapper-inner grid_12">
                <header>

                                            <div class="site-logo">
                        <a href="/"><img
                                    src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/web_smdr_logo_2018_master.png"
                                    alt="San Marcos Record Logo"/></a>
                        </div>                    
                </header>

            </div>
        </div>

    </div>
</div>


    <div class="main-menu-wrapper clearfix">
        <div class="main-menu-wrapper-inner">
            <nav id="main-menu">
                  <div class="region region-main-menu">
    <div id="block-superfish-1"
     class="block block-superfish">
    <div class="block-inner">

                      <h3 class="title">
              <span>Main menu</span></h3>
            
        <div class="content">
          <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-navbar sf-style-space sf-total-items-13 sf-parent-items-0 sf-single-items-13"><li id="menu-656-1" class="first odd sf-item-1 sf-depth-1 sf-no-children"><a href="/" title="" class="sf-depth-1"><span>Home</span></a></li><li id="menu-1284-1" class="middle even sf-item-2 sf-depth-1 sf-no-children"><a href="/news" title="News" class="sf-depth-1"><span>News</span></a></li><li id="menu-1285-1" class="middle odd sf-item-3 sf-depth-1 sf-no-children"><a href="/sports" title="Sports" class="sf-depth-1"><span>Sports</span></a></li><li id="menu-2339-1" class="middle even sf-item-4 sf-depth-1 sf-no-children"><a href="/opinions-0" title="Opinions" class="sf-depth-1"><span>Opinions</span></a></li><li id="menu-2422-1" class="middle odd sf-item-5 sf-depth-1 sf-no-children"><a href="/features" title="Features" class="sf-depth-1"><span>Features</span></a></li><li id="menu-2424-1" class="middle even sf-item-6 sf-depth-1 sf-no-children"><a href="/obituary" title="Obituary" class="sf-depth-1"><span>Obituary</span></a></li><li id="menu-3332-1" class="middle odd sf-item-7 sf-depth-1 sf-no-children"><a href="/calendar" class="sf-depth-1"><span>Calendar</span></a></li><li id="menu-2425-1" class="middle even sf-item-8 sf-depth-1 sf-no-children"><a href="https://etypeservices.com/SWF/LocalUser/Etypeclass1/Magazine45331/Full/index.aspx?II=45331" title="" class="sf-depth-1"><span>Classifieds</span></a></li><li id="menu-3338-1" class="middle odd sf-item-9 sf-depth-1 sf-no-children"><a href="/music-listings" class="sf-depth-1"><span>Music</span></a></li><li id="menu-2170-1" class="middle even sf-item-10 sf-depth-1 sf-no-children"><a href="/contact" title="" class="sf-depth-1"><span>Contact</span></a></li><li id="menu-3334-1" class="middle odd sf-item-11 sf-depth-1 sf-no-children"><a href="/archives" class="sf-depth-1"><span>Archives</span></a></li><li id="menu-3333-1" class="middle even sf-item-12 sf-depth-1 sf-no-children"><a href="https://www.mercolocal.com/affiliates/hays-marketplace" title="" class="sf-depth-1"><span>Hays Marketplace</span></a></li><li id="menu-3321-1" class="last odd sf-item-13 sf-depth-1 sf-no-children"><a href="/toy-insider" title="Toy Insider" class="sf-depth-1"><span>Toy Insider</span></a></li></ul>        </div>

    </div>
</div>
  </div>
            </nav>
        </div>
    </div>

    <div class="main-menu-second-level-wrapper clearfix">
        <div class="main-menu-second-level-wrapper-inner">
            <nav id="main-menu-second-level">
                  <div class="region region-main-menu-second-level">
    <div id="block-block-57"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <p class="rtecenter">&nbsp;</p>
<center><script type="text/javascript"><!--
google_ad_client = "ca-pub-6055882063795349";
/* EType_RON */
google_ad_slot = "EType_RON";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></center>
<p class="rtecenter">&nbsp;</p>        </div>

    </div>
</div>
  </div>
            </nav>
        </div>
    </div>

<div id="page">
    <div class="page-inner container_12">

        <!-- Main Content -->
        <div class="main-content-wrapper clearfix">
            <div class="main-content-wrapper-inner">
                <section id="main-content">

                    <div class="main">
                        <div class="main-inner grid_8">

                                                            <div class="slideshow-wrapper clearfix">
                                    <div class="slideshow-wrapper-inner">
                                        <div id="slideshow">
                                              <div class="region region-slideshow">
    <div id="block-simpleads-ad-groups-797"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-797', 797, 1);
  </script>
    <div class="simpleads-797"></div>

    
</div>
        </div>

    </div>
</div>
<div id="block-block-63"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <table align="center" border="0" cellpadding="5" cellspacing="5" style="width:100%;">
	<tbody>
		<tr>
			<td class="rtecenter" style="background-color: rgb(51, 51, 51); border-color: rgb(51, 51, 51);">
			<h6 class="rteleft"><span style="font-size:16px;"><span style="color:#ffffff;">As a public service, public health stories are free to Central Texans during the coronavirus crisis. Please support our local journalists by subscribing today. Call 512-392-2458.</span></span></h6>
			</td>
		</tr>
	</tbody>
</table>
        </div>

    </div>
</div>
  </div>
                                        </div>
                                    </div>
                                </div>
                            
                                                                                                                                              <div class="region region-content">
    <div id="block-system-main"
     class="block block-system">
    <div class="block-inner">

                  
        <div class="content">
          <article id="node-210589" class="node node-article last clearfix" about="/sports/maggie-walsh-stays-home-commits-texas-state" typeof="sioc:Item foaf:Document">

    <div class="node-content-wrapper">
                <div class="field-image">
            <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="og:image rdfs:seeAlso" resource="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/juicebox_large/public/field/image/real_walsh_web_edit.jpg?itok=S_fqONS_"><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/juicebox_large/public/field/image/real_walsh_web_edit.jpg?itok=S_fqONS_" width="2048" height="1509" alt="Article Image Alt Text" /><blockquote class="image-field-caption">
  <p>Photo by Gerald Castillo</p>
</blockquote>
</div></div></div>          </div>
      
      
      
      
                <h1 class="title">Maggie Walsh stays home, commits to Texas State</h1>
      
      <span property="dc:title" content="Maggie Walsh stays home, commits to Texas State" class="rdf-meta element-hidden"></span>
                          <!-- Go to www.addthis.com/dashboard to customize your tools -->
          <div class="addthis_sharing_toolbox"></div>
                
                <div class="submitted clearfix">
              <span class="date"><span property="dc:date dc:created" content="2020-12-12T13:24:54-06:00" datatype="xsd:dateTime">Sat, 12/12/2020 - 1:24pm</span></span>
          </div>
      
        <div id="pico">
            <div class="content">
              <div class="field field-name-field-subhead field-type-text field-label-hidden"><div class="field-items"><div class="field-item even">San Marcos Volleyball</div></div></div><div class="field field-name-field-reporter field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/drew-king" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>Drew King</span></a></div></div></div><div class="field field-name-field-author-title field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/sports-editor" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>Sports Editor</span></a></div></div></div><div class="field field-name-field-url field-type-link-field field-label-hidden"><div class="field-items"><div class="field-item even"><a href="http://twitter.com/drewking0222"><span>@drewking0222</span></a></div></div></div><div class="field field-name-field-email field-type-email field-label-hidden"><div class="field-items"><div class="field-item even"><a href="mailto:dking@sanmarcosrecord.com"><span>dking@sanmarcosrecord.com</span></a></div></div></div><div class="field field-name-field-date1 field-type-datetime field-label-hidden"><div class="field-items"><div class="field-item even"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2020-12-12T00:00:00-06:00">Saturday, December 12, 2020</span></div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Maggie Walsh is surprised by how fast she became committed to her dream school.</p>
<p>A year ago, she thought she would play libero if she made it to the collegiate level — though she didn’t have much interest from coaches as a sophomore. But after moving to San Marcos, switching to an outside hitter position and taking the Lady Rattlers to new heights this season, the San Marcos junior received an offer from Texas State on Tuesday.</p>
<p>It was an opportunity to stay close to home. Her parents could come and watch her play all the time. It was also an opportunity to join forces with a program that just won its third-straight Sun Belt Conference tournament championship.</p>
<p>Walsh accepted the offer Wednesday evening.</p>
<p>“That's what kind of attracted me to it, was like, it's right here,” Walsh said. “But then getting to know them more and keeping up with their season, just winning the conference and then their coaching styles and how it's very similar to (Lady Rattlers head coach Jared Te'o), it just seemed like somewhere I would really want to go to.”</p>
<p>Maggie transferred to San Marcos from Denton Guyer over the summer after her father, John Walsh, was hired as the Rattlers’ athletic director and football coach in May.</p>
<p>Te’o was hired as head volleyball coach in June and began looking over the roster to see what pieces he had to work with. Some of the players were members of the club team he coaches, Austin Juniors Volleyball. However, he didn’t know much about Maggie, though a mutual acquaintance, Kim Slusser, reached out to give him some background.</p>
<p>Slusser is a friend of the Walsh’s. Her daughter, Brooke, played with Maggie at Guyer and was coached by Te’o at his former club team, Texas Advantage Volleyball.</p>
<p>“But like, she's a mom. Like, she's not a coach,” Te’o said. “She's like, ‘(Maggie) was pretty good for us but I don't know how good she'll be to turn a program around.’”</p>
<p>Te’o found highlights of Maggie online. They were mostly clips of her playing defense. But the Lady Rattlers needed more firepower on offense. When they finally met in person, Te’o told Maggie he wanted to use her as the team’s No. 1 scorer. He wasn’t blown away by her hitting skill early on, but he could tell she had potential.</p>
<p>“She was mediocre at best, and that sounds really mean, as an attacker when she got here,” Te’o said. “Like, she just kind of hit hard. And I was like, ‘OK, that's cute, but like, what else can you do?’”</p>
<p>The head coach worked with Maggie on expanding her hitting range, developing different ways to spike the ball over the net from a variety of angles. It didn’t come naturally to junior but she worked at it until it felt comfortable.</p>
<p>The move paid off for San Marcos. Walsh led the team with 5.1 kills per set as the Lady Rattlers claimed a 10-9 overall record in the regular season and and 8-6 record in district play, securing a spot in the playoffs.</p>
<p>Walsh’s defensive experience gave her a unique edge, especially in serve receive.</p>
<p>“Every coach in our district, their scouting report is how to slow down Maggie,” Te’o said. “So a big thing they do is, and it's like kind of 'Coaching 101,' they try to serve the go-to player. And like, coaches noticed really early on, serving Maggie actually plays to our benefit because she's our best passer. So they had to really just try to take her out offensively.”</p>
<p>Walsh and her teammates took a 3-1 upset victory over Austin Vandegrift on the road on Nov. 20 in the first round of the playoffs, giving San Marcos its first postseason win since 2001. The season concluded in the next round as the Lady Rattlers fell to San Antonio Reagan, 3-0.</p>
<p>Walsh and Te’o discussed what interest Maggie was getting from college teams throughout the season. There was one school in particular Walsh had an eye on.</p>
<p>“At the very beginning when we both moved here, (Te'o) asked me like, ‘What college do you want to go to? And what would be your dream?’” Walsh said. “And I said Texas State. Like Texas State would be my dream school to go to.”</p>
<p>Te’o is good friends with Texas State head coach Sean Huiet and associate head coach Keith Anderson, and has coached Bobcat outside hitter Janell Fitzgerald and libero Kayla Granado at the club level. He knew his relationship with Texas State could be a blessing or a curse when it came to recruiting.</p>
<p>“At the end of the day, college athletics is a business,” Te’o said. “So I have a lot of kids on my club team that I coach and a lot of kids over the years who wanted to play for people who I'm friends with. And it can always be an awkward conversation to be like, ‘Hey, I know you're one of my kids, but you're not what they're looking for.’”</p>
<p>The Bobcats are a championship-winning program. At 5-foot-10, Walsh will be a bit undersized as a college hitter. Te’o told Maggie early on to keep all her options open.</p>
<p>But as the season progressed and Walsh improved to the point that she picked up First Team All-District 26-6A and Most Valuable Hitter honors, Te’o realized the she could actually be a great fit at Texas State. Huiet and Anderson agreed, leading to Walsh's commitment. Te’o called it “one of the easiest sells” he’s ever had to make.</p>
<p>Walsh will play for the top Austin Juniors Volleyball team this club season and work with Te’o during spring training to sharpen her skills so she can thrive with the maroon and gold. She’s ecstatic to already have her recruiting process out of the way.</p>
<p>“Honestly, it kind of feels surreal,” Walsh said. “Like, I really wasn't expecting that to happen so fast. But it did and I'm excited. It kind of feels like a lot of pressure is off of me now.”</p>
</div></div></div>            </div>
        </div>

                    
                <nav class="taxonomy">
              <div class="taxonomy-inner clearfix">
                <div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/sports" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>Sports</span></a></div></div></div>              </div>
          </nav>
      
                <nav class="taxonomy">
              <div class="taxonomy-inner clearfix">
                <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="dc:subject"><a href="/san-marcos-news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>San Marcos News</span></a></div><div class="field-item odd" rel="dc:subject"><a href="/san-marcos-record" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype=""><span>San Marcos Record</span></a></div></div></div>              </div>
          </nav>
      
    </div>

</article>

    <div class="free-message">
      <a href="https://etypeservices.com/San%20Marcos%20RecordID328/" target="_blank">Subscribe and see the e-Edition of the San Marcos Record for the complete story.</a>    </div>

        </div>

    </div>
</div>
<div id="block-block-65"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <div id="rc-widget-754a4a" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="140365"></div>
<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
        </div>

    </div>
</div>
  </div>
                                                    </div>

                        <aside class="sidebar second-sidebar grid_4 clearfix">
                              <div class="region region-sidebar-first">
    <div id="block-simpleads-ad-groups-480"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-480', 480, 1);
  </script>
    <div class="simpleads-480"></div>

    
</div>
        </div>

    </div>
</div>
<div id="block-block-48"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <p class="rtecenter"><a href="https://www.facebook.com/sanmarcosrecord" target="_blank"><img alt="" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/article_body_upload/facebook-newblue40x40.gif" style="width: 40px; height: 40px;" /></a>  <a href="https://twitter.com/sanmarcosrecord" target="_blank"><img alt="" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/article_body_upload/twitter-newblue40x40.gif" style="width: 40px; height: 40px;" /></a>  <a href="https://www.instagram.com/sanmarcosrecord/" target="_blank"><img alt="" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/article_body_upload/instagram-newblue40x40.gif" style="width: 40px; height: 40px;" /></a>  <a href="https://www.etypeservices.com/San%20Marcos%20RecordID328/default.aspx?PubID=1213" target="_blank"><img alt="" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/article_body_upload/subscribe-newblue100x40.gif" style="width: 100px; height: 41px;" /></a></p>
        </div>

    </div>
</div>
<div id="block-simpleads-ad-groups-776"
     class="block block-simpleads">
    <div class="block-inner">

                  
        <div class="content">
          <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-776', 776, 1);
  </script>
    <div class="simpleads-776"></div>

    
</div>
        </div>

    </div>
</div>
<div id="block-block-1"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <center><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=107313" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;z-index: 1;position: relative;margin: -20px 0 0 0;display: block;text-indent: -9999em" href="https://www.willyweather.com/tx/hays-county/san-marcos.html" rel="nofollow">The latest weather for san marcos</a></div></center>        </div>

    </div>
</div>
<div id="block-block-59"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <p class="rtecenter">&nbsp;</p>
<div style="margin: -40px 0 -30px -21px;">
<script type="text/javascript"><!--
google_ad_client = "ca-pub-6055882063795349";
/* EType_RON */
google_ad_slot = "EType_RON";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>        </div>

    </div>
</div>
<div id="block-block-38"
     class="block block-block">
    <div class="block-inner">

                      <h3 class="title">
              <span><a href="https://twitter.com/smdrsports?lang=en" class="block-title-link"><span>@SMDRSports</span></a></span></h3>
            
        <div class="content">
          <center><a class="twitter-timeline" data-width="250" data-height="300" href="https://twitter.com/smdrsports?ref_src=twsrc%5Etfw">Tweets by smdrsports</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center>        </div>

    </div>
</div>
<div id="block-etype-e-edition"
     class="block block-etype">
    <div class="block-inner">

                  
        <div class="content">
          
<p class="rtecenter"><a href="https://etypeservices.com/San%20Marcos%20RecordID328/"><img src="https://etypeservices.com/LandingPageImages/San%20Marcos%20Record/currentpg1.jpg" alt="San Marcos Record e-Edition" /></a></p><h4 class="rtecenter"><a href="https://etypeservices.com/San%20Marcos%20RecordID328/">Click here to read San Marcos Record</a></h4>
        </div>

    </div>
</div>
  </div>
                              <div class="region region-sidebar-second">
    <div id="block-dfp-tpa-northsidebar"
     class="block block-dfp">
    <div class="block-inner">

                  
        <div class="content">
          <div id="dfp-ad-tpa_northsidebar-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-tpa_northsidebar" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-tpa_northsidebar");
    });
  </script>
</div>
</div>        </div>

    </div>
</div>
<div id="block-block-62"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <center><a class="twitter-timeline" data-width="300" data-height="400" href="https://twitter.com/sanmarcosrecord?ref_src=twsrc%5Etfw">Tweets by sanmarcosrecord</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center>        </div>

    </div>
</div>
<div id="block-etype-facebook"
     class="block block-etype">
    <div class="block-inner">

                      <h3 class="title">
              <span>Facebook</span></h3>
            
        <div class="content">
          
 <div class="fb-page" data-href="https://www.facebook.com/sanmarcosrecord" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"></div>
            </div>

    </div>
</div>
<div id="block-block-60"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <p class="rtecenter">&nbsp;</p>
<div style="margin: -40px 0 -30px -21px;">
<script type="text/javascript"><!--
google_ad_client = "ca-pub-6055882063795349";
/* EType_RON */
google_ad_slot = "EType_RON";
google_ad_width = 300;
google_ad_height = 600;
//-->
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>        </div>

    </div>
</div>
  </div>
                        </aside>
                    </div>

                </section>
            </div>
        </div>

          <div class="region region-content-bottom">
    <div id="block-views-business-directory-block-1"
     class="block block-views">
    <div class="block-inner">

                      <h3 class="title">
              <span>Service Directory</span></h3>
            
        <div class="content">
          <div class="view view-business-directory view-id-business_directory view-display-id-block_1 view-dom-id-2957c196740dc614f736ef68516ea7e7">
        
  
  
      <div class="view-content">
      <ul class="jcarousel jcarousel-view--business-directory--block-1 jcarousel-dom-1 jcarousel-skin-default">
      <li class="jcarousel-item-1 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://mytekrescue.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/tekrescue_1.jpg?itok=GL6sVCzo" width="100" height="70" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://mytekrescue.com/"><span>TekRESCUE</span></a></p>  </div></li>
      <li class="jcarousel-item-2 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="http://www.lifechangesestatesales.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/life_changes_estate_solutions_logo_1.jpg?itok=fjC9kg25" width="100" height="100" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="http://www.lifechangesestatesales.com/"><span>Life Changes Estate Sales</span></a></p>  </div></li>
      <li class="jcarousel-item-3 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="http://hillsoftexassky.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/hills_of_texas_sky_realty_logo.png?itok=I0EBPvQB" width="100" height="27" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="http://hillsoftexassky.com/"><span>Hills of Texas Realty</span></a></p>  </div></li>
      <li class="jcarousel-item-4 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="http://gibson-properties.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/gibson_properties_logo.png?itok=ZEVHgX3K" width="100" height="41" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="http://gibson-properties.com/"><span>Gibson Properties</span></a></p>  </div></li>
      <li class="jcarousel-item-5 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://grinsrestaurant.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/grins_restaurant_logo.jpg?itok=Kri6klT1" width="100" height="75" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://grinsrestaurant.com/"><span>Grins Restaurant</span></a></p>  </div></li>
      <li class="jcarousel-item-6 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://www.gsmyc.org/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/greater_san_marcos_youth_council_logo.png?itok=yygGTSt6" width="95" height="100" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://www.gsmyc.org/"><span>Greater San Marcos Youth Council</span></a></p>  </div></li>
      <li class="jcarousel-item-7 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://www.germerinsurance.com/san-marcos-texas"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/germer_insurance_services_logo.png?itok=pd2oAl4r" width="100" height="64" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://www.germerinsurance.com/san-marcos-texas"><span>Germer Insurance</span></a></p>  </div></li>
      <li class="jcarousel-item-8 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://belcantofarms.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/bel_canto_farms_logo.jpg?itok=hh7fWMK5" width="100" height="35" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://belcantofarms.com/"><span>Bel Canto Farms</span></a></p>  </div></li>
      <li class="jcarousel-item-9 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://www.sanmarcostso.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/texas_state_optical_logo.png?itok=UkO8zR8v" width="100" height="55" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://www.sanmarcostso.com/"><span>Texas State Optical</span></a></p>  </div></li>
      <li class="jcarousel-item-10 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://royalorangetradingco.com/contact-royal-orange-trading-co/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/royal_orange_trading_company_logo_2.png?itok=oUzNL7aW" width="100" height="100" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://royalorangetradingco.com/contact-royal-orange-trading-co/"><span>Royal Orange Trading Company</span></a></p>  </div></li>
      <li class="jcarousel-item-11 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://ptrc-tx.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/physical_therapy_and_rehab_concepts_ptrc_logo.jpg?itok=ZF1BvKKw" width="100" height="65" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://ptrc-tx.com/"><span>Physical Therapy and Rehab Concepts (PTRC)</span></a></p>  </div></li>
      <li class="jcarousel-item-12 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="http://mypremiercuts.com/"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/premier_cuts_logo.jpg?itok=u66kZLuk" width="100" height="52" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="http://mypremiercuts.com/"><span>Premier Cuts</span></a></p>  </div></li>
      <li class="jcarousel-item-13 odd" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://www.pakmail.com/stores/san-marcos-north?utm_source=google&amp;utm_medium=local&amp;utm_campaign=localmaps&amp;utm_content=17002"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/pakmail_-_thorpe_lane.png?itok=aAD5f5zm" width="100" height="100" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://www.pakmail.com/stores/san-marcos-north?utm_source=google&amp;utm_medium=local&amp;utm_campaign=localmaps&amp;utm_content=17002"><span>PAKMAIL - Thorpe Lane</span></a></p>  </div></li>
      <li class="jcarousel-item-14 even" style="display: none;">  
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="https://www.pakmail.com/stores/pak-mail-san-marcos"><span><img typeof="foaf:Image" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/styles/thumbnail/public/pakmail_-_san_marcos.png?itok=BQkXkDMA" width="100" height="100" alt="Article Image Alt Text" /></span></a></div>  </div>  
  <div>        <p><a href="https://www.pakmail.com/stores/pak-mail-san-marcos"><span>PAKMAIL - San Marcos</span></a></p>  </div></li>
  </ul>
    </div>
  
  
  
  
  
  
</div>        </div>

    </div>
</div>
  </div>

                    <div class="postscript-wrapper clearfix">
                <div class="postscript-wrapper-inner">
                    <div class="postscript-wrapper-inner-inner">
                        <section id="postscript">
                            <div class="grid_4">  <div class="region region-postscript-1">
    <div id="block-block-3"
     class="block block-block">
    <div class="block-inner">

                      <h3 class="title">
              <span>San Marcos Record</span></h3>
            
        <div class="content">
          <p>(512) 392-2458<br />
P.O. Box 1109, San Marcos, TX 78666</p>
        </div>

    </div>
</div>
  </div>
</div>
                            <div class="grid_4">  <div class="region region-postscript-2">
    <div id="block-menu-block-2"
     class="block block-menu-block">
    <div class="block-inner">

                      <h3 class="title">
              <span>Site Links</span></h3>
            
        <div class="content">
          <div class="menu-block-wrapper menu-block-2 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="first leaf menu-mlid-656"><a href="/" title=""><span>Home</span></a></li>
<li class="leaf menu-mlid-1284"><a href="/news" title="News"><span>News</span></a></li>
<li class="leaf menu-mlid-1285"><a href="/sports" title="Sports"><span>Sports</span></a></li>
<li class="leaf menu-mlid-2339"><a href="/opinions-0" title="Opinions"><span>Opinions</span></a></li>
<li class="leaf menu-mlid-2422"><a href="/features" title="Features"><span>Features</span></a></li>
<li class="leaf menu-mlid-2424"><a href="/obituary" title="Obituary"><span>Obituary</span></a></li>
<li class="leaf menu-mlid-3332"><a href="/calendar"><span>Calendar</span></a></li>
<li class="leaf menu-mlid-2425"><a href="https://etypeservices.com/SWF/LocalUser/Etypeclass1/Magazine45331/Full/index.aspx?II=45331" title=""><span>Classifieds</span></a></li>
<li class="leaf menu-mlid-3338"><a href="/music-listings"><span>Music</span></a></li>
<li class="leaf menu-mlid-2170"><a href="/contact" title=""><span>Contact</span></a></li>
<li class="leaf menu-mlid-3334"><a href="/archives"><span>Archives</span></a></li>
<li class="leaf menu-mlid-3333"><a href="https://www.mercolocal.com/affiliates/hays-marketplace" title=""><span>Hays Marketplace</span></a></li>
<li class="last leaf menu-mlid-3321"><a href="/toy-insider" title="Toy Insider"><span>Toy Insider</span></a></li>
</ul></div>
        </div>

    </div>
</div>
  </div>
</div>
                            <div class="grid_4"></div>
                        </section>
                                            </div>
                </div>
            </div>
                              <div class="region region-footer">
    <div id="block-block-37"
     class="block block-block">
    <div class="block-inner">

                  
        <div class="content">
          <p class="rtecenter">San Marcos Daily Record Copyright © 2020</p>
        </div>

    </div>
</div>
<div id="block-dfp-tpa-northleaderboard"
     class="block block-dfp">
    <div class="block-inner">

                  
        <div class="content">
          <div id="dfp-ad-tpa_northleaderboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-tpa_northleaderboard" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-tpa_northleaderboard");
    });
  </script>
</div>
</div>        </div>

    </div>
</div>
  </div>
            </div>
</div><!-- page -->

<div id="page-bottom">
    </div><script type="text/javascript" src="https://www.sanmarcosrecord.com/sites/sanmarcosrecord.etypegoogle4.com/files/js/js_MLVgtzZ1ORq9krYqkeOsRay6ou_T-0QZytivuM9tTT8.js"></script>
<script src="/sites/all/libraries/smart-app-banner/dist/smart-app-banner.js"></script>
 <script type="text/javascript">
      new SmartBanner({
          daysHidden: 15,   // days to hide banner after close button is clicked (defaults to 15)
          daysReminder: 90, // days to hide banner after "VIEW" button is clicked (defaults to 90)
          appStoreLanguage: 'us', // language code for the App Store (defaults to user's browser language)
          title: 'San Marcos Daily Record',
          author: 'San Marcos Daily Record',
          button: 'VIEW',
          store: {
              ios: 'On the App Store',
              android: 'In Google Play',
              windows: 'In Windows store'
          },
          price: {
              ios: 'FREE',
              android: 'FREE',
              windows: 'FREE'
          }
          // , theme: '' // put platform type ('ios', 'android', etc.) here to force single theme on all device
          // , icon: '' // full path to icon image if not using website icon image
          // , force: 'ios' // Uncomment for platform emulation
      });
</script>

<style>
#menu-3321-1 {
    background: #19B049!important;
}
#menu-3321-1 a.active {
    background: #19B049!important;
}
</style></body>
</html>
